Java proteus-quickstart: gradle: Can't build rsocket-rpc-protobuf


#1

Hi guys,
I’m trying out the Java quickstart demo, but I’m getting an error during the task: Task :service-idl:generateProto. Can you plese help me? I like this tecnology, I would like to try and may be
use it in the near feture in company, thanks. (I’ve tried on OSX and Windows…)

Below my log:

./gradle build
bash: ./gradle: is a directory
Markus:proteus Marco$ ./gradlew build
Downloading gradle-4.10-bin.zip

Unzipping … gradle

Welcome to Gradle 4.10!

Here are the highlights of this release:

  • Incremental Java compilation by default
  • Periodic Gradle caches cleanup
  • Gradle Kotlin DSL 1.0-RC3
  • Nested included builds
  • SNAPSHOT plugin versions in the plugins {} block

Starting a Gradle Daemon (subsequent builds will be faster)

Task :service-idl:generateProto FAILED

FAILURE: Build failed with an exception.

  • What went wrong:
    Could not resolve all files for configuration ‘:service-idl:protobufToolsLocator_rsocketRpc’.

Could not find rsocket-rpc-protobuf-osx-x86_64.exe (io.rsocket.rpc:rsocket-rpc-protobuf:0.2.12).
Searched in the following locations:
https://repo.maven.apache.org/maven2/io/rsocket/rpc/rsocket-rpc-protobuf/0.2.12/rsocket-rpc-protobuf-0.2.12-osx-x86_64.exe

  • Try:
    Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output. Run with --scan to get full insights.

  • Get more help at https://help.gradle.org

BUILD FAILED in 1m 10s
3 actionable tasks: 3 executed

PS: can you please change the policy of the topic? When I’m trying to save the post it says: “Sorry, new users can only put 2 links in a post.” which is very annoying… thanks


#2

Hi Marco,

Did you check this out recently? Can you try running clean with your build and see if that helps?

./gradlew clean build

We’ll take a look at the policy.

Thanks,
Robert


#3

Hi Robert, I tried, but I got the same error, : it doesn’t find the file https://repo.maven.apache.org/maven2/io/rsocket/rpc/rsocket-rpc-protobuf/0.2.12/rsocket-rpc-protobuf-0.2.12-osx-x86_64.exe. On https://repo.maven.apache.org/maven2/io/rsocket/rpc/rsocket-rpc-protobuf/0.2.12 there
is only the linux version, no OSX no Windows version.
Bellow the error:

  • What went wrong:
    Could not resolve all files for configuration ‘:service-idl:protobufToolsLocator_rsocketRpc’.

Could not find rsocket-rpc-protobuf-osx-x86_64.exe (io.rsocket.rpc:rsocket-rpc-protobuf:0.2.12).
Searched in the following locations:
url that I can’t write due to the policy… rsocket-rpc-protobuf-0.2.12-osx-x86_64.exe

Thank you Robert.


#4

Hi,

Did some more looking. It does appear that the other mac version didn’t make it to maven cental. They are in jcenter though. Is jcenter the first repository listed in the build.gradle? I’ll contact bintray and figure out why they didn’t get promoted to maven central.

Thanks,
Robert


#5

Thanks Robert,
they don’t have the windows version either.

Thank you again.

M.


#6

Robert,

I would suggest to modify the build.gradle repositories part, in the Java proteus-quickstart prj, from:

repositories {    
    mavenCentral()
	jcenter()
    maven {
        url 'https://dl.bintray.com/netifi/netifi-oss/'
    }
}

to
repositories {
jcenter()
mavenCentral()
maven {
url ‘https://dl.bintray.com/netifi/netifi-oss/
}
}

and this works perfectly. :slight_smile:

Thanks.

Marco


#7

Hi,

Latest quickstart has been updated to jcenter first. The exe’s should be making their way to maven central too.

Thanks,
Robert


#8

Cool!

Thanks man!

Marco.


#9

I am trying also to build with windows but don’t see the version in either jcenter, dl.bintray, or maven central. Oh where could these be located. Thanks.


#10

Hello @btodd22. When you say you don’t see the version, what do you mean exactly? A build error or are you searching those repositories manually? I see the Windows version of the RSocket-RPC binary here:

https://jcenter.bintray.com/io/rsocket/rpc/rsocket-rpc-protobuf/0.2.12/

rsocket-rpc-protobuf-0.2.12-windows-x86_64.exe

If that’s not what you mean, could you please clarify?


#11

False alarm here. It had to do with jcenter having issues with their servers. I am now seeing the correct jar I need. Thank you.