Java proteus-quickstart: Maven PROTOC FAILED issue


I am using Maven and its failing while i build mvn clean install. any help would be appriciated. Becasue our company have high chance to use this if this works.

ERROR] PROTOC FAILED: --rsocketRpc_out: protoc-gen-rsocketRpc: This version of %1 is not compatible with the version of Windows you’re running. Check your computer’s system information to see whether you need a x86 (32-bit) or x64 (64-bit) version of the progra
m, and then contact the software publisher.

Any update on this issue would be much appreciated as we want to experiment this as alternative for existing solution.


Hi Proteus team, in relation to this issue I would also like to switch from gradle to maven cause also my company use it. So please let me know.



Sorry guys, my mistake, it works for me with maven. (it was a problem of my test machine)


Hi Marco, Could you share what is the protoc-gen-rsocketRpc version you see in your machine. Wants to know, is that issue with my windows version.


Hi, I don’t know if it is useful, but maven downloads protoc-3.6.1-windows-x86_64.exe and rsocket-rpc-protobuf-0.2.12-windows-x86_64.exe on my Windows10.


Thank you Marco. I believe, I see same version and don’t know why it’s not working.



We’ll take a look into this. What version of windows are you using?



Hi Robert,

I have window-x86_64 and it’s on window 7 enterprise edition.



I tried on Windows 10 too and it seemed to work fine. - I’ll see if I can get a windows 7 vm somewhere and give it a shot. That could be the issue.


Thank you Robert. I’m keeping my fingers crossed :slight_smile:


Hi Karthik,

Haven’t forgotten about you. Trying to find a windows 7 VM to test this with.



Hi Karthik,

Do you know if you are running a 32-bit or 64-bit Windows 7?



Thank you Robert. I have x64-based PC.

As I said, This is really important to explore as we want to moved towards reactive programming and also want to find alternative for current messaging system. I really want to get to the bottom before i say anything to my team to look alternatives.

thank you again :slight_smile:


Ok - I will try find a 64-bit Windows 7-ish VM then and test this out.


Found a Windows 7 machine - I was only able to replicate your error when I tried on 32-bit operating system. Is it possible that you have a 32-bit version of windows installed on 64-bit system?


Hi Robert,

I have verified and its says x64-based PC and based on the below link if the * For a 64-bit version operating system, x64-based PC appears for the System type under Item .


Hello @kkarthik.

I’m taking a look into this issue and trying to reproduce your set up. I’m spinning up a VM with Windows 7 64-bit, VS 2015, JDK 11. What have I missed?


Hi Kyle,

Thank you and here is my setup.
Window 7 Enterprise
64 bit OS on X64 based PC



@kkarthik I have good news and bad news :slight_smile:

I have a VM with
Windows 7 Ultimate, 64-bit
JDK 1.8 u201 (slight difference here?)
Maven 3.6.0

And everything works just fine running mvn clean install from the proteus-quickstart root directory. Is there something I’m missing about your set up or a known significant difference between JDK 1.8 u201 and 1.8 u144 ?

Running mvn with -X, I see that I’m pulling the 1.5.3 version of the Proteus artifacts and 0.2.12 of rsocket-rpc-protobuf plugin. Are you seeing the same?


I do see the same version of proteus and rsocket but i am not sure the windows 7 enterprise is same as windows 7 ultimate.

thank you